dtlPlayershops

Premium MC Plugin dtlPlayershops 1.1.8
Playershops with the looks and feels of dtlTraders

DONATION LINK FOR DEVELOPER: http://4creation.pro/donate
26c4265bd2a7b8098fa3aa6b8c676475c554d299


dtlPlayershops was made so players can easily setup shops using npc's.
From setup for owners to players that makes and manage shops are all GUI based.
Seriously, no hassle with configs and commands
;)



Do you like dtlPlayershops? Let other people know by a review!
Join discord to get involved in future updates or get/give help from/to other server owners.
Features:
  • Easy way to setup and manage shops using a GUI
  • Make/edit your shops just by drag and drop items
  • 2 types of shops: Buy & Sell
  • Set limits and decide what your players can edit in there shop using permission packages
  • Support of vanilla and custom NBT/DataTags
  • NBT/DataTags makes custom item from 3rd party plugins possible
  • Advanced users can customize there own items using the configs.
  • Allows stack trades
  • ANY economy plugin support
  • Compatible with spigot/bukkit 1.8 - 1.15.x
  • Change descriptions and names of your items
  • Adjust shop interaction with "custom input amount" and "stack shift"
  • More navigation buttons and GUI modules with a aim to "One GUI"
Installation:
  • Download dtlPlayershops.jar and place it into your plugins folder.
  • Download Citizens (Citizens2) and place that into your plugins folder as well.
  • You also need Vault and ANY economy plugin.
  • Start your server.
  • Installation is done.
Simple guide:
  • Create a permission package (/dtlp -> Permission package (first item) -> "Create Permission Package" (Emerald)
  • Make your shops using /dtlp create "name"
  • Add the items in your inventory that you want to sell in the shop
  • Manage/edit shops content using /dtlp edit
  • In the edit options you can drag/drop items, set prices, set names and much more .
  • You are done
  • for all the commands -> /dtlp help
▶ Video tutorial:

In progress
:coffee:


☊ Versions:


Did you know that dtlPlayerShops V1.0.0 supports bukkit/spigot version 1.8 - 1.15.x ?


Contact or Issues:
For questions or suggestions:

  • PM me
  • Join Discord channel: https://discord.gg/fyabsMF
  • Send a mail to: [email protected]
  • Like
Reactions:notchme2988, Anusjaved and Mateko
Author
FateKid
Downloads
0
Total Views
461
Released
Version
1.1.8
Rating
0.00 star(s) 0 ratings

More files from FateKid

Share this resource